Back to overview
Resolved

Service Disruption

Aug 3, 2026 at 11:15pm UTC
Affected services
laiusentertainment.com
Laius Verify
Moderation System

Resolved
Aug 4, 2026 at 7:33am UTC

All services are back online. Thanks for your patience.

Created
Aug 3, 2026 at 11:15pm UTC

We’re currently experiencing a service outage due to a local storm. Thanks for your patience.