Back to overview
Resolved

Service Downtime

Jun 1, 2026 at 4:50pm UTC
Affected services
laiusentertainment.com
Merch Shop
Laius Web API
Moderation System

Resolved
Jun 1, 2026 at 5:05pm UTC

Everything is back to normal now. Thanks for being patient.

Updated
Jun 1, 2026 at 5:00pm UTC

Power is back and we’re currently restoring services. Everything should be coming back online now.

Created
Jun 1, 2026 at 4:50pm UTC

We’re currently experiencing a service outage due to a local storm impacting our power supply. We’re working on it and will be back up as soon as things stabilize. Thanks for your patience.